Not getting this to work in VR.

Discussion in 'General Discussion' started by Navigator, May 27, 2022.

  1. Navigator

    Navigator Member

    Nov 27, 2020
    +6 / 0 / -0
    Hi guys,

    Just bought a Lenovo Explorer and tried this game.
    I have to say; I have no controllers with it, but they said it was optional and should be okay.

    Well, did all they said, including the line -vr
    But when I start, the screen is about 10 feet below me; I get the (I think) default steam vr screen with the lines and the stars, and right beneath me, there is the starting screen. I can move my mouse over it and once managed to go to a race; when I got there, I hoovered 10 feet above the car.......

    Now I tried assigning the buttons for centering (found that one later) and that was a problem too; trying to start the game without vr, didn't work; no matter what I did, it started op steam vr too.
    Again; once managed it and assigned.

    Now when the screen is below me, I can use that button and its in front of me.
    Okay, so now I can have a go.......NO! The mouse won't work!
    Before; it did. Now, nope!
    Pressing the windows and Y key to move over the controls as Lenovo(?) keeps saying is not the solution.

    I'm out of ideas.
    Does anyone have a good hint for me please?
  2. morsify

    morsify Active Member

    Jan 20, 2019
    +36 / 0 / -0
    I've had a similar problem (Reverb G2 WMR). I can't remember exactly, but I know that, when I fire up the game, steamvr kicks in, then I get the screen, as you say, way down below my sitting position and I have to 'reset vr view' to get it into the centre.

    While the game is firing up, I must not touch (click on) anything else or the wrong window becomes the priority and the mouse can then fail to appear in the game (actually it is still present, but it is on the desktop instead of in the game).
    I'm pretty sure (and it would be logical) that it should be RRE that is on top of all others, if not I would suggest you try highlighting different windows on the desktop (steamvr, steam itself, or RRE) and one of them should make the mouse appear in game.

    (So, in other words, start the game, but when steammvr kicks in, make sure rre is still the top window, then put the headset on).

    Hope that helps somehow.
  3. Skybird

    Skybird Well-Known Member

    Mar 31, 2015
    +803 / 0 / -0
    Launch the game in 2D and map a button to "centre VR", or however it is called in English. Then exit, and launch again in 3d/VR. Kneel on the floor if oyu must to see the screen, whent he text emssage appears, click a button to continue, and then hit the button you reserved for centering VR.

    If that does not work, you set a sub-optimal option in your hardware's software, I do not recall it in all detail from memory correctly maybe, but there must be a point during setup of your VR hardware when they ask whether you want your position autoadjusted to the room scaling (necessary for the virtual security cage you see to avoid collision with furniture and walls), or not. You probably have it on, switch it off. Thats what I did with my Reverb G2.

    I now have at laucnh the screen in VR a meter below me, I waot a few seconds, then hit the VR centering button, and it jumps up to my face where I look straight.

    Handcontrollers you do not need for racing.

    If buttons and keyboard and mouse do not work, it can be, like the previous poster said, that the headset activates an internal VR working mode that is designed for controller handling, and by that keyboard and mouse get blocked. Take the VR headset off, so that the sensor does not detect any body temperature, this should unlock keyboard and mouse, you can do your settings needed, and then you try again. You may need to bind a key to switching monitor on and off , if it is black when you take off the helmet.

    P.S. I have no clue on the Lenovo Explorer, I talk be experience with Oculus Rift and Reverb G2.
    Last edited: May 28, 2022
  4. Skybird

    Skybird Well-Known Member

    Mar 31, 2015
    +803 / 0 / -0
    P.S. Also you cna start via Steam. Hitting the game's start button there should give you 4 options: 32 and 64 Bit, 32 and 64 Bit Steam VR.
    Chose wisely. :)
    The command parameter -vr you need to alter every time they have altered the exe in a patch, thats why I do not care for that method anymore.